MyDeveloperDay added a comment. > Sounds good to me. I see that you've made D57966 > <https://reviews.llvm.org/D57966> a child of this issue, but we could swap > the dependency around so that once your patch is applied I can update this > patch to use `camelBackOrCase`.
I'm OK if we want to do that, but its very much a circular dependency, I don't want to land D57966: [clang-tidy] add camelBackOrCase casing style to readability-identifier-naming to support change to variable naming policy (if adopted) <https://reviews.llvm.org/D57966>, unless this whole variableName suggestion is accepted (which I think is a good idea).. I think your suggestion warrants being the driver, lets do the clang-tidy change and subsequent .clang-tidy changes on another revision post acceptance of both. FWIW, I agree with the comments that the function name should be differentiated from the variable by the use of a verbs, I've spent too much time in my career grepping for the work `type` in code Type type = type(); I think Type type = getType(); or Type objectType = getType(); adds some increased levels of clarity. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D57896/new/ https://reviews.llvm.org/D57896 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits