LegalizeAdulthood added inline comments. ================ Comment at: clang-tidy/readability/RedundantReturnCheck.cpp:24 @@ +23,3 @@ + functionDecl(isDefinition(), returns(asString("void")), + has(compoundStmt(hasAnySubstatement(returnStmt())))) + .bind("fn"), ---------------- aaron.ballman wrote: > Would be best to restrict this to a return statement that has no expression > if we don't want to diagnose this: > ``` > void g(); > > void f() { > return g(); > } > ``` > Either way, it would be good to have a test that ensures this isn't mangled. How about transforming this odd looking duck into
``` void g(); void f() { g(); } ``` ? http://reviews.llvm.org/D16259 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits