nickdesaulniers added inline comments.
================ Comment at: lib/Parse/ParseStmtAsm.cpp:830-858 + if (AteExtraColon || Tok.is(tok::colon)) { + if (AteExtraColon) + AteExtraColon = false; + else + ConsumeToken(); + + if (!AteExtraColon && Tok.isNot(tok::identifier)) { ---------------- jyu2 wrote: > nickdesaulniers wrote: > > ``` > > if (x || y) { > > if (x) foo(); > > else bar(); > > if (!x && ...) baz(); > > if (!x && ...) quux(); > > ``` > > is maybe more readable as: > > ``` > > if (x) foo(); > > else if (y) > > bar(); > > baz(); > > quux(); > > ``` > This is better? IIUC, it looks like `ConsumeToken()` modifies `Tok`, so the 2 `isNot` cases should fail as expected when `!AteExtraColon`, so this change LGTM. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D56571/new/ https://reviews.llvm.org/D56571 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits