NoQ added a comment. In https://reviews.llvm.org/D52984#1294233, @aaron.ballman wrote:
> Personally, I think it's detrimental to the community for subprojects to come > up with their own coding guidelines. My preference is for the static analyzer > to come more in line with the rest of the project (over time, organically) in > terms of style, terminology, diagnostic wording, etc. However, if the > consensus is that we want a separate coding standard, I think it should be > explicitly documented somewhere public and then maintained as part of the > project. I tihnk it's mostly conventions of using Analyzer-specific APIs, eg. avoid `addTransition()` hell - i guess we already have that, or how to register custom immutable maps, or how to implement checker dependencies or inter-checker APIs, or how much do we want to split modeling and checking into separate checkers, stuff like that. ================ Comment at: www/analyzer/checker_dev_manual.html:719 +<ul> +<li>User facing documentation is important for adoption! Make sure the check list updated + at the homepage of the analyzer. Also ensure that the description is good quality in ---------------- aaron.ballman wrote: > xazax.hun wrote: > > Szelethus wrote: > > > xazax.hun wrote: > > > > Szelethus wrote: > > > > > Make sure the **checker** list **is** updated > > > > I think at some point we should decide if we prefer the term check or > > > > checker to refer to these things :) Clang Tidy clearly prefers check. > > > That is the distinction I'm aware of too: checkers in the Static > > > Analyzer, checks in clang-tidy. > > My understanding is the following: we want users to use the term `check`, > > since that is more widespread and used by other (non-clang) tools as well. > > The term `checker` is something like a historical artifact in the developer > > community of the static analyzer. But if this is not the case, I am happy > > to change the terminology. But I do want to have some input from rest of > > the community too :) > I grew up with the term "checker", but I feel like "check" may have won the > war. I don't have a strong opinion here though. We have the word "checker" all over the website, in option names, and, most importantly, in the "How to write a //checker// in 24 hours" video. I don't think we have much choice (: https://reviews.llvm.org/D52984 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits