alexfh accepted this revision. alexfh added a comment. This revision is now accepted and ready to land.
Thanks! Looks good with one nit. Do you need me to commit the patch for you? ================ Comment at: clang-tidy/readability/SimplifyBooleanExprCheck.cpp:519 @@ +518,3 @@ + + DiagnosticBuilder diagnostic = diag(Loc, Description); + if (!containsDiscardedTokens(Result, CharRange)) ---------------- The name `diagnostic` violates [[ http://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly | LLVM naming rules ]]. Should be `Diagnostic` (or `Diag`, since this variant is consistent with the corresponding function name and used widely across clang-tidy code). http://reviews.llvm.org/D15737 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits