zaks.anna added inline comments.

================
Comment at: tools/scan-build-py/README.md:86
@@ +85,3 @@
+The 2. mode is available only on FreeBSD, Linux and OSX. Where library preload
+is available from the dynamic loader. On OSX System Integrity Protection 
security
+feature enabled prevents library preload, so this method will not work in such
----------------
This is very unfortunate!

We should call out that library interposition is "not supported on OS X (unless 
System Integrity Protection feature is turned off)" and return an error if 
people are trying to use it (and System Integrity Protection feature is turned 
on).

================
Comment at: tools/scan-build-py/bin/analyze-build:17
@@ +16,2 @@
+from libscanbuild.analyze import main
+sys.exit(main(this_dir, False))
----------------
Please rename 'main'.

================
Comment at: tools/scan-build-py/bin/analyze-c++:3
@@ +2,3 @@
+# -*- coding: utf-8 -*-
+#                     The LLVM Compiler Infrastructure
+#
----------------
I searched the code and did not see it being called. By looking back at the 
previous revision I see that that libscanbuild.analyze.main used to call 
'analyze-cxx' not 'analyze-c++'. Looks like you've also fixed the same bug with 
'intercept-c++'. 

Is this something that could/would be caught by the tests?

================
Comment at: tools/scan-build-py/bin/analyze-cc:14
@@ +13,2 @@
+from libscanbuild.analyze import scan_build_wrapper
+sys.exit(scan_build_wrapper(False))
----------------
Could you rename **all** of the public functions, not just this one? I am 
talking about the other wrapper and several main functions used as the entry 
points in the scripts.

================
Comment at: tools/scan-build-py/bin/intercept-build:17
@@ +16,2 @@
+from libscanbuild.intercept import main
+sys.exit(main(this_dir))
----------------
Please rename 'main'.

================
Comment at: tools/scan-build-py/bin/intercept-c++:14
@@ +13,2 @@
+from libscanbuild.intercept import wrapper
+sys.exit(wrapper(True))
----------------
Please rename 'wrapper'.

================
Comment at: tools/scan-build-py/bin/intercept-cc:14
@@ +13,2 @@
+from libscanbuild.intercept import wrapper
+sys.exit(wrapper(False))
----------------
Please rename 'wrapper'.

================
Comment at: tools/scan-build-py/bin/scan-build:17
@@ +16,2 @@
+from libscanbuild.analyze import main
+sys.exit(main(this_dir, True))
----------------
Please rename 'main'.


http://reviews.llvm.org/D9600



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to