alexfh added inline comments. ================ Comment at: clang-tidy/readability/IdentifierNamingCheck.cpp:577-578 @@ -578,3 +576,4 @@ Diag << FixItHint::CreateReplacement( - CharSourceRange::getTokenRange(Range), Failure.Fixup); + SourceRange(SourceLocation::getFromRawEncoding(Loc)), + Failure.Fixup); } ---------------- I'd like the comment to cover destructors, operator names and other cases where the actual name consists of multiple tokens (which are probably filtered out somewhere, as we don't need to fix naming for these).
Fine for a follow-up. Repository: rL LLVM http://reviews.llvm.org/D13079 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits