hfinkel added inline comments.

================
Comment at: lib/Driver/Tools.cpp:4232
@@ +4231,3 @@
+                   false))
+    CmdArgs.push_back(Args.MakeArgString("-force-align-stack"));
+
----------------
echristo wrote:
> hfinkel wrote:
> > The code below for OPT_mstackrealign uses -mstackrealign as the name of the 
> > backend option too. Why not do the same for OPT_mstackrealign (use 
> > -mstackrealign as the name of the backend option) instead of inventing a 
> > new flag name -force-align-stack?
> In general we don't do that. But I also don't want this to use a backend 
> option anyhow, why are we doing that here once we have the attribute?
It's not a backend option, this is the flag being passed from the driver to 
clang -cc1.



http://reviews.llvm.org/D11815



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to