Bryan,

That message means that you have added those properties to your config but they 
do not exist.

The link that Molly Kewl provided shows all variables that can be set at 
mgmt.xxx
Notice versionControl is a class, so properties there will be, 
mgmt.versionControl.xxx

Finally, case matters for variable names; userReposDir != userreposdir

Ray

On Wed, 2020-07-08 at 14:16 -0600, Bryan Wooten wrote:
So when we load the app on the same Tomcat as the CAS server itself we get this 
error:

***************************
APPLICATION FAILED TO START
***************************

Description:

Binding to target [Bindable@1471d5e6 type = 
org.apereo.cas.configuration.CasManagementConfigurationProperties, value = 'pro
vided', annotations = 
array<Annotation>[@org.springframework.boot.context.properties.ConfigurationProperties(ignoreInvalidF
ields=false, ignoreUnknownFields=false, prefix=mgmt, value=mgmt)]] failed:

    Property: mgmt.enabledelegatedmgmt
    Value: false
    Origin: "mgmt.enableDelegatedMgmt" from property source 
"bootstrapProperties"
    Reason: The elements 
[mgmt.enabledelegatedmgmt,mgmt.enableversioncontrol,mgmt.servicesrepo,mgmt.userreposdir]
 were left
 unbound.
    Property: mgmt.enableversioncontrol
    Value: false
    Origin: "mgmt.enableVersionControl" from property source 
"bootstrapProperties"
    Reason: The elements 
[mgmt.enabledelegatedmgmt,mgmt.enableversioncontrol,mgmt.servicesrepo,mgmt.userreposdir]
 were left
 unbound.
    Property: mgmt.servicesrepo
    Value: /etc/cas/config/services/servicesRepo
    Origin: "mgmt.servicesRepo" from property source "bootstrapProperties"
    Reason: The elements 
[mgmt.enabledelegatedmgmt,mgmt.enableversioncontrol,mgmt.servicesrepo,mgmt.userreposdir]
 were left
 unbound.
    Property: mgmt.userreposdir
    Value: /etc/cas/config/userRepo
    Origin: "mgmt.userreposdir" from property source "bootstrapProperties"
    Reason: The elements 
[mgmt.enabledelegatedmgmt,mgmt.enableversioncontrol,mgmt.servicesrepo,mgmt.userreposdir]
 were left
 unbound.

Action:

Update your application's configuration

We have tried adding unbound to management.properties, adding directly to 
bootstrap.properties in the exploded war file and putting a copy of 
bootstrap.properties in /etc/cas/config.

But I always get the error.

We are building the Master branch from: 
https://github.com/apereo/cas-management-overlay/

Any help appreciated.

-Bryan

University of Utah

--

Ray Bon
Programmer Analyst
Development Services, University Systems
2507218831 | CLE 019 | [email protected]<mailto:[email protected]>

I respectfully acknowledge that my place of work is located within the 
ancestral, traditional and unceded territory of the Songhees, Esquimalt and 
WSÁNEĆ Nations.

-- 
- Website: https://apereo.github.io/cas
- Gitter Chatroom: https://gitter.im/apereo/cas
- List Guidelines: https://goo.gl/1VRrw7
- Contributions: https://goo.gl/mh7qDG
--- 
You received this message because you are subscribed to the Google Groups "CAS 
Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To view this discussion on the web visit 
https://groups.google.com/a/apereo.org/d/msgid/cas-user/e45ed68907667665d5ec6ceb0e5cb193091e3423.camel%40uvic.ca.

Reply via email to