Sounds like a Tomcat issue. The version you’re on isn’t the latest so there could be something there. You should also try getting a stock tomcat installation directly rather than one from the repos, if you don’t wish to use the embedded jetty.
Ref: https://github.com/jboss-javassist/javassist/issues/29 From: Paul Chauvet [mailto:[email protected]] Sent: Friday, February 5, 2016 2:12 PM To: Misagh Moayyed <[email protected]> Subject: RE: [cas-user] javassist error when starting CAS Hi Misagh, I eventually would be adding a lot to the pom.xml file, but to (in theory) eliminate errors and establish that my environment was setup correctly I didn’t add anything. I was working from the pom.xml file at: https://raw.githubusercontent.com/Jasig/cas-overlay-template/master/pom.xml I downloaded that to the system, built it (mvn clean package), copied the cas.war file into /usr/share/tomcat/webapps, and started tomcat. Paul Chauvet Information Security Officer State University of New York at New Paltz [email protected] <mailto:[email protected]> 845-257-3828 From: [email protected] <mailto:[email protected]> [mailto:[email protected]] On Behalf Of Misagh Moayyed Sent: Friday, February 05, 2016 3:58 PM To: [email protected] <mailto:[email protected]> Subject: RE: [cas-user] javassist error when starting CAS Certainly not obvious. What have you added to the pom besides what’s there, if anything? From: [email protected] <mailto:[email protected]> [mailto:[email protected]] On Behalf Of Paul Chauvet Sent: Friday, February 5, 2016 12:59 PM To: [email protected] <mailto:[email protected]> Subject: [cas-user] javassist error when starting CAS Hi all, I’m starting the process of moving to a newer version of CAS, specifically 4.1 (we’re currently on 3.4.x). I’ve started out clean with the following: · RHEL 7 · Tomcat 7.0.54 (latest version from RedHat’s repos) · Maven 1.7.0_95 · JDK 1.7.0_95 · To start with at least, pom.xml directly from (https://github.com/Jasig/cas-overlay-template) After building the war file and deploying it, CAS fails to start due to errors. There are a ton of them, all about javassist-3.19.0-GA.jar. I’ve included one of those stack traces below. I’ve been unable to find what specifically is causing this error (I saw some posts online about issues with JDK 8, which is what I started with, but going back to JDK 7 didn’t seem to change things). Any ideas as to what could be causing this? My apologies if this is something obvious that I missed. Thanks in advance for any advice you can provide. Stack trace: Feb 05, 2016 2:02:26 PM org.apache.catalina.startup.ContextConfig processAnnotationsJar SEVERE: Unable to process Jar entry [javassist/ByteArrayClassPath.class] from Jar [jar:file:/usr/share/tomcat/webapps/cas/WEB-INF/lib/javassist-3.19.0-GA.jar!/] for annotations java.io.EOFException at java.io.DataInputStream.readUnsignedShort(DataInputStream.java:340) at org.apache.tomcat.util.bcel.classfile.Utility.swallowMethodParameters(Utility.java:797) at org.apache.tomcat.util.bcel.classfile.Attribute.readAttribute(Attribute.java:171) at org.apache.tomcat.util.bcel.classfile.FieldOrMethod.<init>(FieldOrMethod.java:57) at org.apache.tomcat.util.bcel.classfile.Method.<init>(Method.java:71) at org.apache.tomcat.util.bcel.classfile.ClassParser.readMethods(ClassParser.java:267) at org.apache.tomcat.util.bcel.classfile.ClassParser.parse(ClassParser.java:127) at org.apache.catalina.startup.ContextConfig.processAnnotationsStream(ContextConfig.java:2058) at org.apache.catalina.startup.ContextConfig.processAnnotationsJar(ContextConfig.java:1934) at org.apache.catalina.startup.ContextConfig.processAnnotationsUrl(ContextConfig.java:1900) at org.apache.catalina.startup.ContextConfig.processAnnotations(ContextConfig.java:1885) at org.apache.catalina.startup.ContextConfig.webConfig(ContextConfig.java:1317) at org.apache.catalina.startup.ContextConfig.configureStart(ContextConfig.java:876) at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:374) at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117) at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:90) at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5355) at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150) at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901) at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877) at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:632) at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:1083) at org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1880) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) at java.util.concurrent.FutureTask.run(FutureTask.java:262) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at java.lang.Thread.run(Thread.java:745) Paul Chauvet Information Security Officer State University of New York at New Paltz [email protected] <mailto:[email protected]> 845-257-3828 -- You received this message because you are subscribed to the Google Groups "CAS Community" group. To unsubscribe from this group and stop receiving emails from it, send an email to [email protected] <mailto:[email protected]> . Visit this group at https://groups.google.com/a/apereo.org/group/cas-user/. -- You received this message because you are subscribed to the Google Groups "CAS Community" group. To unsubscribe from this group and stop receiving emails from it, send an email to [email protected] <mailto:[email protected]> . Visit this group at https://groups.google.com/a/apereo.org/group/cas-user/. -- You received this message because you are subscribed to the Google Groups "CAS Community" group. To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]. Visit this group at https://groups.google.com/a/apereo.org/group/cas-user/.
