Miguel Figueiredo, le Mon 27 May 2013 23:30:17 +0100, a écrit : > in case you feel it is worth it:
I'm balanced. It is small enough not to have to really care about performance, and stuffing #if makes the code less readable. > diff --git a/kern/thread.c b/kern/thread.c > index 79f526a..574f184 100644 > --- a/kern/thread.c > +++ b/kern/thread.c > @@ -163,10 +163,14 @@ boolean_t stack_alloc_try( > > if (stack != 0) { > stack_attach(thread, stack, resume); > +#if MACH_DEBUG > stack_alloc_hits++; > +#endif /* MACH_DEBUG */ > return TRUE; > } else { > +#if MACH_DEBUG > stack_alloc_misses++; > +#endif /* MACH_DEBUG */ > return FALSE; > } > }