Hi,

Thomas Schwinge, le Sun 05 Nov 2006 22:34:56 +0100, a écrit :
> #v+
> @@ -221,16 +223,16 @@ i386_set_ldt(thread, first_selector, des
> [...]
> -           else if (thread == current_thread()) {
> -               struct x86_desc template = {0, 0, 0, ACC_P, 0, 0 ,0};
> +           else {
> +               struct real_descriptor template = {0, 0, 0, ACC_P, 0, 0 ,0};
> #v-
> 
> The following differences might be caused simply by the OSKit Mach code
> being different from the GNU Mach one,

Exactly. Just the names differ.

> -      for (idx = sel_idx (USER_GDT); idx < sel_idx (USER_GDT) + 
> USER_GDT_SLOTS;
> -          ++idx)
> +      for (idx = 0; idx < USER_GDT_SLOTS; ++idx)

There was a mixture of index / selector in this code, which eventually
wasn't working.  Defining idx between 0 an USER_GDT_SLOT-1 makes the
whole code easier to read, and eventually work :).

> >             * linux/dev/include/linux/head.h: New file.
> 
> Please move that file to `linux/src/include/linux/head.h' (and then add a
> proper ChangeLog entry for that file).  I'm not going to follow the `src'
> vs. `dev' distinction any further.

Ah.  I guess this policy change should be clearly stated somewhere.

Samuel


_______________________________________________
Bug-hurd mailing list
Bug-hurd@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-hurd

Reply via email to