Hi Paul, > > it's better ignore which > > parts of the API will be used frequently or rarely. Better think only at > > how easy it is to remember each item. > > Even if that's the criterion, I find it easier to remember "use _GL_NORETURN > for > most noreturn cases, and use _GL_ATTRIBUTE_NORETURN for when you want just > the > noreturn attribute" than to remember "use _GL_NORETURN_FUNC for most noreturn > cases, and use _GL_NORETURN_FUNCPTR for when you want just the noreturn > attribute".
I disagree again. The user should not need to know about whether the macros expand to a keyword, an attribute, or whatever. That's part of their implementation, which is meant to be opaque. Seems we can't agree. Therefore I won't propose a short name '_GL_NORETURN'. Bruno