On 08/18/2011 07:53 AM, Jim Meyering wrote:
From: Jim Meyering<meyer...@redhat.com>
---
lib/fts.c | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/fts.c b/lib/fts.c
index 776dda5..b8b7c5a 100644
--- a/lib/fts.c
+++ b/lib/fts.c
@@ -1192,7 +1192,7 @@ set_stat_type (struct stat *st, unsigned int dtype)
st->st_mode = type;
}
-# define __opendir2(file, flag) \
+# define __opendir2(file) \
See my earlier comments. As soon as we are no longer matching the BSD
definition of __opendir2, then we should no longer be using a name that
might cause conflict with the BSD definition. How about naming the
macro fts_opendir instead?
--
Eric Blake ebl...@redhat.com +1-801-349-2682
Libvirt virtualization library http://libvirt.org