Ralf Wildenhues <[EMAIL PROTECTED]> writes: > Furthermore, if I may suggest not to sprinkle hard-coded numbers all > over the place. How about something like this > #define ARCFOUR_BLOCKBITS 8 > #define ARCFOUR_BLOCKSIZE (1 << ARCFOUR_BLOCKBITS) > #define ARCFOUR_BLOCKMASK (ARCFOUR_BLOCKSIZE - 1)
Wasn't that backwards? Shouldn't it be: #define ARCFOUR_BLOCK_SIZE 8 #define ARCFOUR_BLOCK_BITS (1 << ARCFOUR_BLOCKSIZE) #define ARCFOUR_BLOCK_MASK (ARCFOUR_BLOCKBITS - 1) ? Symbols called *SIZE are usually measured in bytes. I have made this change in my local copy. (As well as adding a SPC for easier reading..) _______________________________________________ bug-gnulib mailing list bug-gnulib@gnu.org http://lists.gnu.org/mailman/listinfo/bug-gnulib