Stepan Kasal wrote: > > > m4_ifndef([AC_HEADER_STDBOOL], > > > AC_DEFUN([AC_HEADER_STDBOOL], > > > > Nope, this would be a regression. > > Oh, I understand now. But I don't think gnulib should redefine documented > Autoconf macros. What about renaming it to gl_HEADER_STDBOOL ?
A guiding principle for gnulib is to write code in a way that abstracts away other software's bugs. We write #include <getopt.h> when /usr/include/getopt.h does not do what we want bool var; although gcc-2.95 didn't have a working 'bool' AC_HEADER_STDBOOL because the test in autoconf-2.59 is buggy. The idea behind this is 1) to simplify our code, 2) to make pressure on the other software maintainers, showing them how it would be correct, 3) We want to minimize the work we have to do when a software fixes its bugs. (We have already enough work detecting the bugs...) We do override include files by using our own if the system's one is defective. We do #define bool to hide the one provided by the compiler. We do override an autoconf macro if it is buggy. Doing this is more reliable that using our replacement under a different name, say <gl_getopt.h> or gl_bool or gl_HEADER_STDBOOL. The hope is that someday there will be an autoconf release that fixes that bug in AC_HEADER_STDBOOL. Bruno _______________________________________________ bug-gnulib mailing list bug-gnulib@gnu.org http://lists.gnu.org/mailman/listinfo/bug-gnulib