Paul Eggert <[EMAIL PROTECTED]> wrote: ... > This subject has come up a couple of times before. In > <http://lists.gnu.org/archive/html/bug-coreutils/2005-06/msg00156.html> > I noted that glibc now sometimes uses the following style when the > type isn't known to be a structure or a scalar: > > sometype somevar = { 0, }; > > as an indication to the reader as to what is going on. > > The question is whether we want to use this style, which I think is > nicer, or cater to "gcc -Wall" even if its warning is > counterproductive. Personally I'd rather do the former, so I'd prefer > the following patch, but it's really up to Jim.
I do prefer your patch. You're welcome to check that in. > 2006-10-09 Paul Eggert <[EMAIL PROTECTED]> > > * lib/quotearg.c (quotearg_buffer_restyled): Use > initializer rather than memset to initialize an object > to zero. This is easier to read and is less likely to > introduce an runtime error due to a mixup. It causes > "gcc -Wall" to issue a warning, but you can work around > this by appending -Wno-missing-braces. > * src/ls.c (quote_name): Likewise. > * src/pathchk.c (portable_chars_only): Likewise. > * src/shred.c (main): Likewise. > * src/stty.c (main): Likewise. > * src/tr.c (card_of_complement): Likewise. > * src/wc.c (wc): Likewise. _______________________________________________ Bug-coreutils mailing list Bug-coreutils@gnu.org http://lists.gnu.org/mailman/listinfo/bug-coreutils