STT_IFUNC is defined in OS-specific range:
#define STT_LOOS 10 /* OS-specific semantics */
#define STT_IFUNC 10 /* Symbol is an indirect code object */
#define STT_HIOS 12 /* OS-specific semantics */
It should be STT_GNU_IFUNC. Unless everyone agrees it should be 7,
which is generic to all OSes, it should be renamed to STT_GNU_IFUNC.
--
Summary: STT_IFUNC is in OS-specific range
Product: binutils
Version: 2.20 (HEAD)
Status: NEW
Severity: normal
Priority: P2
Component: ld
AssignedTo: unassigned at sources dot redhat dot com
ReportedBy: hjl dot tools at gmail dot com
CC: bug-binutils at gnu dot org,nickc at redhat dot com
http://sourceware.org/bugzilla/show_bug.cgi?id=7103
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.
_______________________________________________
bug-binutils mailing list
[email protected]
http://lists.gnu.org/mailman/listinfo/bug-binutils