After implementing the metadata functions nnn⍙Provides, nnn⍙Requires, etc,
I feel that we should change this slightly.

I find the that multitude of functions to support this tend to pollute the
output of )FNS quite a bit. It's also somewhat inflexible in that it
requires you to add even more functions as new features are added to the
package system.

How about we change this so that only one function is used, for example
nnn⍙package_metadata or something like that? The name matters less, but the
point is that it's only a single function.

I find this to be a lot cleaner.

As an example, for SQL, the content would be:

*      8⎕CR SQL⍙package_metadata*
┌→─────────────────────────────────────────────────┐
↓┌→─────┐   ┌→──────────────┐                      │
││Author│   │Elias Mårtenson│                      │
│└──────┘   └───────────────┘                      │
│┌→───────┐ ┌→──────────────┐                      │
││BugEmail│ │bug-apl@gnu.org│                      │
│└────────┘ └───────────────┘                      │
│┌→───────┐ ┌→────────────────────────────────────┐│
││Download│ │https://github.com/lokedhs/apl-sqlite││
│└────────┘ └─────────────────────────────────────┘│
│┌→──────┐  ┌→───┐                                 │
││License│  │LGPL│                                 │
│└───────┘  └────┘                                 │
│┌→───────┐ ┌→──┐                                  │
││Provides│ │SQL│                                  │
│└────────┘ └───┘                                  │
│┌→──────┐  ┌→──┐                                  │
││Version│  │1.0│                                  │
│└───────┘  └───┘                                  │
└∊─────────────────────────────────────────────────┘

Regrads,
Elias

Reply via email to