Bryan R Harris wrote:

: Okay, I'll rename it to something else -- but I still want
: it to be called "_uc" in my code and maybe just "u"
: available to the user.  Is this possible?

    Yes. You can have another sub call _uc(). 

sub u {
    return _uc(@_);
}


    Subroutines are in the Symbol Table. You could associate
(I'm not certain that is the correct term) another name with
this sub using a glob. You can read more about this in Symbol
Tables section of "perlmod" file of the documentation, but it
may rob you of some sanity. :)


local *convert = \&_uc;

    Calling convert() will now do the same as calling _uc().



HTH,

Charles K. Clarkson
-- 
Mobile Homes Specialist
254 968-8328



-- 
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
<http://learn.perl.org/> <http://learn.perl.org/first-response>


Reply via email to