On May 12, 2016, at 7:10 PM, Shawn H Corey wrote: >> my $holders = join ',', ('?') x @cgi_params; > PBP recommends that you put short strings that are all punctuation in > q{}, so they will be easier to read. > > my $holders = join q{,}, (q{?}) x @cgi_params;
I realize stuff like this is subjective, and coding styles can be very personal, but this looks cleaner to me: my $holders = join ',' => ('?') x @cgi_params; Since I found the fat comma, I use it all the time now - especially when two commas are so close together. I'm kind of surprised PBP would say that q{} is easier to read in this situation. IMHO, it seems to just adds noise. Frank -- To unsubscribe, e-mail: beginners-unsubscr...@perl.org For additional commands, e-mail: beginners-h...@perl.org http://learn.perl.org/