On Sat, Feb 24, 2001 at 09:08:37PM -0700, Tom Tromey wrote:
> >>>>> "Akim" == Akim Demaille <[EMAIL PROTECTED]> writes:
>
> Parts of this patch I like, but parts I don't like so much.
>
> Akim> (&file_contents): Be able to grow Automake macros with `+='.
>
> This is a nice idea, but it is problematic. Suppose the user defines
> a variable that a .am file tries to +=. This will fail (I think). I
> think it will fail worse if they only defined the variable
> conditionally.
Yes, I'm not sure how to handle this cleanly, in particular here
where INSTALLDIRS is a fake variable. In fact I first aimed at having
INSTALLDIRS = $(DEST)$(FOODIR)
installdirs:
$(mkinstalldirs) $(INSTALLDIRS)
but it was easier to have
installdirs:
$(mkinstalldirs) $(DEST)$(FOODIR)
We should have some means to delay the output of some variables.
> One approach would be to only ever `+=' private variables -- and then
> maybe add an error if the user tries to override a private variable.
> Also this would mean adding a programming error condition if a .am
> file tries to += a non-private macro.
ISTR there is test somewhere which does this. Hm, it's probably read_main_am
_file which cheks that %contents is empty or something like that.
> Akim> (&handle_texinfo, &handle_man_pages, &am_install_var): Let your
> Akim> files define INSTALLDIRS.
>
> I think we should have a clean separation between internal and
> external variables here. So how about renaming this as
> `_am_installdirs' or something like that? I have a slight preference
> for lower case internal macro names.
Agreed. And a simple s/// will do, so it's fine :)
With this s/// performed it is not clear to me whether this is a yes
or a no :( Given that some of my patches (install-strip.patch) seem
to be already obsoleted I'm really worried.