I found the following in kaffe's configure.in:

AC_CHECK_FUNCS([dnl
strerror hstrerror dnl
fcntl ioctl dnl
alarm setitimer dnl
sigprocmask sigsetmask sigemptyset sigaddset signal sigaction dnl
sbrk valloc memalign mallopt dnl
mprotect madvise dnl
waitpid kill fork execve execvp dnl
sync fsync dnl
atexit on_exit vsnprintf snprintf dnl
])

This appears to no longer work with autoconf 2.53; it causes
seriously confused output. Replacing this idiom with the single-line idiom

AC_CHECK_FUNCS(strerror hstrerror fcntl ioctl alarm setitimer sigprocmask sigsetmask sigemptyset sigaddset signal sigaction sbrk valloc memalign mallopt mprotect madvise waitpid kill fork execve execvp sync fsync atexit on_exit vsnprintf snprintf)

seems to work better, but is hard to read. What's the
proper way to break lines in that situation?
- Dan



Reply via email to