Am 09.04.25 um 15:18 schrieb Ce Sun: > Checking hive is more readable. > > The following smatch warning: > drivers/gpu/drm/amd/amdgpu/amdgpu_device.c:6820 amdgpu_pci_slot_reset() > warn: iterator used outside loop: 'tmp_adev'
Please also remove the setting of hive and tmp_adev to NULL at the declaration. This now becomes unnecessary and I'm pretty sure that some automated checker could complain about that as well. Apart from that looks good to me. Thanks, Christian. > > Fixes: 8ba904f54148 ("drm/amdgpu: Multi-GPU DPC recovery support") > Reported-by: Dan Carpenter <dan.carpen...@linaro.org> > Signed-off-by: Ce Sun <cesun...@amd.com> > --- > drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c > b/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c > index 60269fba5745..eb0589a09a27 100644 > --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c > +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c > @@ -6846,7 +6846,7 @@ pci_ers_result_t amdgpu_pci_slot_reset(struct pci_dev > *pdev) > dev_info(adev->dev, "PCIe error recovery succeeded\n"); > } else { > dev_err(adev->dev, "PCIe error recovery failed, err:%d\n", r); > - if (tmp_adev) { > + if (hive) { > list_for_each_entry(tmp_adev, &device_list, reset_list) > amdgpu_device_unset_mp1_state(tmp_adev); > amdgpu_device_unlock_reset_domain(adev->reset_domain);