On Thu, Mar 27, 2025 at 12:16 AM Alexandre Demers <alexandre.f.dem...@gmail.com> wrote: > > On Mon, Mar 24, 2025 at 2:21 PM Alex Deucher <alexdeuc...@gmail.com> wrote: > > > > On Sat, Mar 22, 2025 at 2:48 PM Alexandre Demers > > <alexandre.f.dem...@gmail.com> wrote: > > > > > > Bring things on a single line and fix spacing. > > > > > > Signed-off-by: Alexandre Demers <alexandre.f.dem...@gmail.com> > > > --- > > > drivers/gpu/drm/amd/amdgpu/dce_v8_0.c | 10 +++------- > > > drivers/gpu/drm/amd/amdgpu/vi.c | 8 ++++++++ > > > 2 files changed, 11 insertions(+), 7 deletions(-) > > > > > > diff --git a/drivers/gpu/drm/amd/amdgpu/dce_v8_0.c > > > b/drivers/gpu/drm/amd/amdgpu/dce_v8_0.c > > > index f008615343c3..533851beb27c 100644 > > > --- a/drivers/gpu/drm/amd/amdgpu/dce_v8_0.c > > > +++ b/drivers/gpu/drm/amd/amdgpu/dce_v8_0.c > > > @@ -3233,8 +3233,7 @@ static const struct amd_ip_funcs dce_v8_0_ip_funcs > > > = { > > > .set_powergating_state = dce_v8_0_set_powergating_state, > > > }; > > > > > > -static void > > > -dce_v8_0_encoder_mode_set(struct drm_encoder *encoder, > > > +static void dce_v8_0_encoder_mode_set(struct drm_encoder *encoder, > > > struct drm_display_mode *mode, > > > struct drm_display_mode *adjusted_mode) > > > { > > > @@ -3330,8 +3329,7 @@ static void dce_v8_0_ext_commit(struct drm_encoder > > > *encoder) > > > > > > } > > > > > > -static void > > > -dce_v8_0_ext_mode_set(struct drm_encoder *encoder, > > > +static void dce_v8_0_ext_mode_set(struct drm_encoder *encoder, > > > struct drm_display_mode *mode, > > > struct drm_display_mode *adjusted_mode) > > > { > > > @@ -3343,8 +3341,7 @@ static void dce_v8_0_ext_disable(struct drm_encoder > > > *encoder) > > > > > > } > > > > > > -static void > > > -dce_v8_0_ext_dpms(struct drm_encoder *encoder, int mode) > > > +static void dce_v8_0_ext_dpms(struct drm_encoder *encoder, int mode) > > > { > > > > > > } > > > @@ -3407,7 +3404,6 @@ static void dce_v8_0_encoder_add(struct > > > amdgpu_device *adev, > > > amdgpu_encoder->devices |= supported_device; > > > return; > > > } > > > - > > > } > > > > > > /* add a new one */ > > > diff --git a/drivers/gpu/drm/amd/amdgpu/vi.c > > > b/drivers/gpu/drm/amd/amdgpu/vi.c > > > index a83505815d39..bcabcf27c3d0 100644 > > > --- a/drivers/gpu/drm/amd/amdgpu/vi.c > > > +++ b/drivers/gpu/drm/amd/amdgpu/vi.c > > > @@ -61,19 +61,27 @@ > > > > > > #include "vid.h" > > > #include "vi.h" > > > + > > > #include "gmc_v8_0.h" > > > #include "gmc_v7_0.h" > > > + > > > #include "gfx_v8_0.h" > > > + > > > #include "sdma_v2_4.h" > > > #include "sdma_v3_0.h" > > > + > > > #include "dce_v10_0.h" > > > #include "dce_v11_0.h" > > > + > > > #include "iceland_ih.h" > > > #include "tonga_ih.h" > > > #include "cz_ih.h" > > > + > > > #include "uvd_v5_0.h" > > > #include "uvd_v6_0.h" > > > + > > > #include "vce_v3_0.h" > > > + > > > #if defined(CONFIG_DRM_AMD_ACP)> #include "amdgpu_acp.h" > > > #endif > > > > What is the reason for these changes? Unless this actually fixes some > > style warning, I'd drop this change. > > > > Alex > > > Readability. Nothing more, nothing less. I'm leaving this up to you to > decide if you want it in or not.
Can you drop this hunk when you send your next respin? Alex > Alexandre > > > > > -- > > > 2.49.0 > > >