Use the swap() macro to simplify the code and improve its
readability.

The target code segment uses the bubble sort, we can use
this macro to simplify the code.

Signed-off-by: Hongbo Li <lihongb...@huawei.com>
---
 drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c 
b/drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c
index 6eccf0241d85..07e9133e8d6d 100644
--- a/drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c
+++ b/drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c
@@ -452,7 +452,6 @@ static void sort_pipes_for_splitting(struct 
dc_plane_pipe_pool *pipes)
 {
        bool sorted, swapped;
        unsigned int cur_index;
-       unsigned int temp;
        int odm_slice_index;
 
        for (odm_slice_index = 0; odm_slice_index < 
pipes->num_pipes_assigned_to_plane_for_odm_combine; odm_slice_index++) {
@@ -468,9 +467,7 @@ static void sort_pipes_for_splitting(struct 
dc_plane_pipe_pool *pipes)
                swapped = false;
                while (!sorted) {
                        if 
(pipes->pipes_assigned_to_plane[odm_slice_index][cur_index] > 
pipes->pipes_assigned_to_plane[odm_slice_index][cur_index + 1]) {
-                               temp = 
pipes->pipes_assigned_to_plane[odm_slice_index][cur_index];
-                               
pipes->pipes_assigned_to_plane[odm_slice_index][cur_index] = 
pipes->pipes_assigned_to_plane[odm_slice_index][cur_index + 1];
-                               
pipes->pipes_assigned_to_plane[odm_slice_index][cur_index + 1] = temp;
+                               
swap(pipes->pipes_assigned_to_plane[odm_slice_index][cur_index], 
pipes->pipes_assigned_to_plane[odm_slice_index][cur_index + 1]);
 
                                swapped = true;
                        }
-- 
2.34.1

Reply via email to