> Do you mean by this that it would be unwise to do something like
> 
> "variable that needs to be = sp" = (jmp_buf) jb[0]
> "variable that needs to be = pc" = (jmp_buf) jb[1]

yes, i think it would be unwise.  i think you mean

                sp = ((uintptr*)jb)[0]
                pc = ((uintptr*)jb)[1]

> this is how other similar ports of this package (GNU portable threads) have 
> been made, for example for win32

it's just my opinion.  i would see such code as peeking through
an deliberately-opaque interface.  and to me that's almost always
a bad idea.  even if it works, and even if other people do it.

others might have other thoughts.

- erik

Reply via email to